Saltar al contenido

Error de Xcode 11 beta 4: el comando CompileSwiftSources falló con un código de salida distinto de cero

Este equipo de redactores ha estado mucho tiempo buscando para dar respuesta a tu duda, te compartimos la resolución por eso nuestro deseo es serte de mucha apoyo.

Solución:

Hay un problema conocido con Cocoapods y Xcode 11 Beta 4 donde inhibit_all_warnings! hace que se establezcan argumentos para Swift que no se compilan. Eliminar esta inhibición resuelve el problema y las advertencias de Swift se pueden inhibir con SWIFT_SUPPRESS_WARNINGS = YES en los objetivos en su lugar.

CocoaPods tenía una solución para esto que se lanzó como parte de CocoaPods 1.7.5.


A continuación se muestra la respuesta que precede a la versión 1.7.5:

Si necesita usar Xcode 11 Beta 4 mientras tanto, puede instalar una versión parcheada de CocoaPods desde esa solicitud de extracción:

1. Abra Gemfile, reemplace gem 'cocoapods' con

gem 'cocoapods', :git => 'https://github.com/dnkoutso/CocoaPods.git', :branch => "swift_compiler_warnings"

2. Corre bundle install y bundle exec pod install

Tenga en cuenta que esta es una solución temporal.

¡La última versión de CocoaPods (1.7.5) solucionó este problema!

  1. En ejecución de terminal

    sudo gem update cocoapods

  2. Y luego, en el directorio de su proyecto

    pod install

Te invitamos a añadir valor a nuestra información contribuyendo tu veteranía en las explicaciones.

¡Haz clic para puntuar esta entrada!
(Votos: 0 Promedio: 0)



Utiliza Nuestro Buscador

Deja una respuesta

Tu dirección de correo electrónico no será publicada.